Problem direct connecting to the ECU

Reply to topic
    Reply with quote

Problem direct connecting to the ECU

Lana Sun Jun 19, 2011 2:19 pm

Maybe somebody can help me out, checked everything but logging straight from the ECU will not work.

I use a EUDM P28, J12 open, Rom tuned with Neptune.
A RS232 to USB adapter (38400, 8, off, 1, off, COM5), RX and TX adapter function checked with Realterm.
Started Neptune an selected Datalogging from COM5 an Log Straight From ECU.
Then selected Datalogger "Start", but nothing happens.
Also tried changing RX an TX at the adapter to ECU connector, without any success.
Also tried a P30 ECU, without any avail as well.

Direct serial logging from an Innovate LM-1 via a second RS232 to USB adapter works fine.

Any idea where the problem could be located? Any input highly appreciated.

Lana

 
Posts: 4
Joined: 19 Jun 2011
    Send private message View user's profile

    Reply with quote

HRTuning Sun Jun 19, 2011 4:22 pm

If it doesn't change to Stop then the software is unable to open the com port.

_________________
Like us on Facebook.
http://www.facebook.com/NepTuneEngineManagement

HRTuning

 
Posts: 10423
Joined: 05 Sep 2004
Location: Phoenix, AZ
    Send private message View user's profile Visit poster's website AIM Address

    Reply with quote

Lana Sun Jun 19, 2011 6:56 pm

It changes to "Stop" but nothing happens. No values at the Gauge or Data Window, nothing.
Except the "Direct Serial" gauge is working
Any idea?

Lana

 
Posts: 4
Joined: 19 Jun 2011
    Send private message View user's profile

    Reply with quote

HRTuning Sun Jun 19, 2011 7:35 pm

That would mean you're not getting any data. Either you're not actually on NepTune, you were tuned on an older version (Pre-2008), or something in between the NepTune software and the ECU is not working properly.

_________________
Like us on Facebook.
http://www.facebook.com/NepTuneEngineManagement

HRTuning

 
Posts: 10423
Joined: 05 Sep 2004
Location: Phoenix, AZ
    Send private message View user's profile Visit poster's website AIM Address

    Reply with quote

Lana Sun Jun 19, 2011 8:23 pm

Just tried again.
When not connected to the ECU it changes to "Stop".
When connected it doesnīt change to "Stop".
As far as I know my Tuner is up to date with his Neptune version.

Lana

 
Posts: 4
Joined: 19 Jun 2011
    Send private message View user's profile

    Reply with quote

HRTuning Sun Jun 19, 2011 9:35 pm

I'm very sorry I overlooked this in your first post, but the ECU doesn't use RS232... so that's your problem. Get the correct hardware, like a Hulog from Moates.net. If you didn't already damage the rx and tx ports then you should be good, but it's possible you did damage.

If you were tuned after 2008 then you're good.

_________________
Like us on Facebook.
http://www.facebook.com/NepTuneEngineManagement

HRTuning

 
Posts: 10423
Joined: 05 Sep 2004
Location: Phoenix, AZ
    Send private message View user's profile Visit poster's website AIM Address

    Reply with quote

Lana Fri Jul 01, 2011 8:29 am

Just solved the problem.
For communication between the ECU and NepTune a TTL to RS232 or USB converter (i.E. Moates HULOG) is required. In my case itīs: ECU > TTL to RS232 > RS232 to USB > NepTune

But another problem has occurred, sometimes only the MAP sensor voltage is shown, but not the "real world" (mbar) value. This problem seems to show up spontaneously, here and then.

Lana

 
Posts: 4
Joined: 19 Jun 2011
    Send private message View user's profile

    Reply with quote

HRTuning Fri Jul 01, 2011 2:51 pm

It's not spontaneous at all. If you don't have a tune open then it doesn't know what map sensor you have selected.

_________________
Like us on Facebook.
http://www.facebook.com/NepTuneEngineManagement

HRTuning

 
Posts: 10423
Joined: 05 Sep 2004
Location: Phoenix, AZ
    Send private message View user's profile Visit poster's website AIM Address


Reply to topic

NepTune Chip Based Questions/Comments

 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum